Issues with NA03 site
Incident Report for Planful
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 08:30 PDT
Investigating
Our monitoring system has generated an alert on NA03, some users might have intermittent issues. Our operations team is actively working on the issue. We will keep you posted.
Posted Oct 06, 2021 - 08:19 PDT
This incident affected: US (NA03).